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A note about QGIS versions 
This workbook was written for QGIS version 3.10.13, the latest long-term release (LTR). If any 
screenshots in the workbook look different to the ones on your screen it is probably 
because you’re on a different version, or have your toolbars positioned differently, but this 
is unlikely to cause any problems. Most QGIS versions are named after where the 
developers have their meetings (e.g. 3.10 is called A Coruña). The LTR version of QGIS is the 
most stable one, but you will also see a newer version of QGIS on the website – these often 
have more features but are not yet finalised for official long-term release.  
 
This workbook is also available online, at: 
https://automaticknowledge.org/training/workbooks 
 
Licence: Attribution-Non Commercial 2.0 Generic (CC BY-NC 2.0) 
https://creativecommons.org/licenses/by-nc/2.0 
 

   

https://automaticknowledge.org/training/workbooks
https://creativecommons.org/licenses/by-nc/2.0
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About Automatic Knowledge 
Our philosophy is all about sharing data 
and knowledge, so that we can all be a bit 
better informed about the world. The way 
we do this is mainly through spatial data 
analysis and visualisation, and as part of 
this we offer training courses in geospatial 
software – mostly QGIS. Alasdair Rae 
(pictured) founded Automatic Knowledge 
in 2019 and also runs the training courses.  
 
Why ‘automatic knowledge’? 
The idea behind Automatic Knowledge is that we do the hard 
work of completing the journey from data to knowledge, so that 
you can then make more informed decisions. These training 
sessions will hopefully help you do that too. 
 
Other activities (e.g. free stuff) 
In addition to training, we provide a range of consultancy 
services, specialising in data, spatial analysis, the built 
environment and cartography. We also publish free and open 
datasets that you may find useful, at: 
 
automaticknowledge.co.uk/resources  
 
We’re also a ‘sustaining member’ of QGIS, which means that we 
donate money to the QGIS project on an annual basis, to help 
fund its development. By taking this course, you’re helping too. 

https://automaticknowledge.co.uk/resources
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Automatic Knowledge training sessions 
The idea behind all our training sessions, and these workbooks, 
is to help you learn new things in an enjoyable way, without 
confusing you. We want everyone who takes one of our courses 
to come away with useful new skills that they can then put into 
practice in their day-to-day work, and build on in the future. 
 
About this workbook 
Following a workbook can be a great way to learn new software 
skills, but there’s also a risk that it turns us into robots, following 
step-by-step instructions in a linear way. During the session 
we’ll go off at tangents and do some demos of useful skills – 
among other things. The emojis? I add them in for a bit of colour, 
but they also serve a practical purpose because they can help 
us find key sections of the document quickly. 
 
Formatting 
Most font is size 14. When switching between screen and 
workbook this is easier on the eyes. The following format will be 
used in relation to files/folders, websites, QGIS options/tools, 
click actions and any text I want you to input. I’ve also added a 
‘Notes’ section on each page where you can jot things down. 
 
Files, folders and suchlike: e.g. world_countries.shp 
Websites: e.g. www.automaticknowledge.org/training 
QGIS windows, tools, sections, options: e.g. Coordinate 
Actions - click menu item/ button: e.g. Vector > Research Tools 
Text input: e.g. "geounit" IN ('Japan','New Zealand') 

http://www.automaticknowledge.org/training
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1. Understanding the QGIS interface 
Okay, let’s begin by starting QGIS (the current version) Once you 
do, you’ll see something like this, below.  
 

 
 
Before we have a play with all the buttons and tools, it’s useful to 
add some map data – otherwise it’s all a bit dull.  
 
In the next section we’re going to add data to QGIS in the proper 
way but for now we’re going to use a little hack to add a world 
map. 
 

 In the Coordinate box at the bottom of the QGIS window, 
delete any numbers that are there, then type in world (all 
lower case) and then press Enter. As if by magic, a world 
map will appear! 

This is where any map 
data you add to QGIS will 

appear – it’s the main 
map viewing area 

Map layers 
appear here 

when you 
add them to 

QGIS 

The file 
Browser 

panel 
See below for 
more on this 
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Now I want you to spend some time getting used to what all the 
tools do for the next little while. Let’s start by changing the map 
projection. 
 

 Click where it says EPSG:4326 in the bottom right of the 
screen. Make sure you’re on the CRS section to the left of 
the Project Properties window and then search for robinson 
in the Filter box and then select World_Robinson from 
Predefined Coordinate Reference Systems and click OK. 

 
 Now I want you to explore the world map with the Map 

Navigation Toolbar – spend a few minutes getting used to 
what they do. If you can’t figure out what any of them do, 
just ask me. Note that if you hover over a tool, you’ll see a 
little tool tip telling you what that tool is or does.  
 

 
 

You might have noticed that you can’t really do 
anything with some of the tools just yet, so let’s 
look at the Attributes Toolbar (shown below) 
 

 
 

 Make sure you can see your full world map (using the 
Zoom Full  button) and then click on the Open Attribute 
Table  button to see the data behind the map.  
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 Click the NAME column header in the Attribute Table to sort 
from A to Z by country – click it again to reverse the sort. 
 

 Click a row number to highlight a country of your choice. If 
you pick a tiny country (e.g. Andorra) you may not see the 
selection (it’s highlighted in yellow on the map) so try not 
to pick a microstate – if you do, just zoom in to see that it is 
highlighted. Move the table if it is obscuring the map. 
 

This is just a little demonstration of the link between the map 
view and the data the lies beneath it. With vector-based GIS 
layers (like the one we’re using now) you’ll always have an 
Attribute Table as part of a layer. 
 
Top tip – click and drag to zoom 
When you’re navigating around maps, you can use the + and –  
magnifying glass tools to zoom in by just clicking on them, but you can 
also click and drag round an area to zoom in or out.  
 

 Let’s make the main map background blue, to look like 
ocean. Go to the Project menu then Properties… and then in 
the General section change the Background color to a blue 
of your choice and then click OK. 

 

Okay, so far, so good. If you’re not used to QGIS it can be a bit 
baffling, but once you know how to navigate your way around a 
map, select things, and see the Attribute Table it’s all much 
easier. See below for how my screen now looks – hopefully yours 
looks similar. 
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Time to save your work 
Now’s a good time to save your work. 
 
Do this now via Project > Save As… and make sure you save the project 
somewhere safe and sensible (i.e. not a temp folder!). This saves your work 
as a QGIS project file (with a qgz file extension). Call the file something like 
qgis_intro_p6 (then a different page number for future saves). Using 
incremental saves like this takes up very little disk space (e.g. 25KB) and 
allows you to go back to different points in the workbook quickly and easily. 

 
Okay, in the next section we’re going to add data to QGIS in the 
way we normally would. 
 

 Start a new project in QGIS by clicking the New Project 
button now (also available via Project > New) and then go 
to the next page of the workbook. 

The Browser and Layer Styling panels   
can be added via the View > Panels menu 
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2. Adding data to QGIS 
The little hack we used to add a world map to QGIS is all very 
well for a bit of exploring but 99% of the time we’ll want to use 
our own data. For the rest of this training session we’ll be using 
the following three datasets. I’ll share the links in a minute. 
 

 A world countries dataset (shapefile and GeoPackage) – 
this is from naturalearthdata.com and is free, open data. 

 A world cities dataset (from a simple text file) – this is from 
simplemaps.com and is also free, open data. 

 A world countries population dataset (from an Excel file) –
this is from data.worldbank.org/indicator/SP.POP.TOTL and 
once again it’s free, open data. 

 
Before we add the data to QGIS we first need to download it. 
 

 Go to https://automaticknowledge.org/training/data/ and 
download datasets 1 to 4. It’s best if you put them in the 
same folder, perhaps one you’ve created for this session – 
just make sure you know where they’re saved to. You’ll 
have to unzip 2_world_countries_shapefile.zip before 
adding it to QGIS, so don’t forget this bit. These are the files 
you’ll get (1 and 2 are different versions of the same data). 

 
 1_world_countries.gpkg 
 2_world_countries_shapefile.zip (unzip after downloading) 
 3_world_cities.csv (this is just a simple text file) 
 4_world_bank_population_data_1960-2019.xlsx 

https://data.worldbank.org/indicator/SP.POP.TOTL
https://automaticknowledge.org/training/data/
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There are loads of ways to get data into QGIS, but the main way 
is via the Data Source Manager – this lets you add loads of 
different kinds of data to QGIS. 
 

 Click the Open Data Source Manager  button to get 
started and you’ll see the Data Source Manager – just like 
the screenshot below. Read the text below to add the data. 

 

 
 
Once you’ve closed the Data Source Manger you should see a 
world map on your screen – the colour is randomly assigned by 
QGIS but we’ll fix that later on. You’ll also see one other file in the 
Layers panel on the left but it’s just a table, with no map data. 

Read this  
To the left you’ll see all the different types of data that can 
be added to QGIS. We’re working with Vector data today, 
but we’ll also add some data using the Delimited Text 
option to the left in a minute or two. 
 
Click the Browse button and then select datasets 1 and 4 
(not 2 or 3 at the moment). You select multiple files to add 
by holding down the CTRL key on Windows or Command 

key on Mac and then clicking the ones you want. Then click 
Open and then Add, then Close the Data Source Manager. 

 
 

Add data using the 
Browse button 
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Baffled? 
If any of this is causing confusion, if you can’t download the data, or  
anything else weird is happening, just let me know and I’ll be happy to help.  

 
Okay, so we’ve added datasets 1 and 4, but what about 2 and 3? 
Well, let’s start by adding in dataset 3, called 3_world_cities.csv. 
You could just open this file in Excel, Word, TextEdit, Notepad or 
any other programme that reads text files and you’d see the text 
shown in the screenshot below. The important thing is that the 
file contains latitude and longitude data (the lat and lng 
columns) so we can easily map it in QGIS.  
 

 
 

 Click the Open Data Source Manager  button again and 
this time, via the Delimited Text option on the left, navigate 
to the 3_world_cities.csv file via the Browse  button and 
then click Open. 
 

 Don’t worry about all the options, we only need to change a 
few things. In the Geometry Definition section just make 
sure X field is set to lng and Y field is set to lat. This lets QGIS 
know where to place the points on the map. Once your 
settings match the ones below, click Add then Close. 
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If you’ve done the last bit right, you’ll now see thousands of dots 
on top of your world map! Yee-ha. 
 

Top tip – change layer order with drag and drop 
If your world cities layer is under your countries layer, it’s easy to fix.  
You can re-arrange the order of map layers in the Layers panel on the left 
by dragging and dropping them up and down. Feel free to try anyway. 

 
 Add dataset 2 now by going to where you saved it on your 

computer, and then drag and drop 2_world_countries.shp 
into the map area in QGIS. This is another way to add data 
to QGIS. Change the layer order if it’s on top of the points. 

  You probably won’t need to edit this section 

 
 

  You probably won’t need to edit this either 

 
 

QGIS shows you a preview of your data, below 
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Remember this 
There are loads of different file formats when you’re working with GIS 
data. The most common one is the shapefile, but unlike the name suggests 
a shapefile is not just one single file, but in fact is made up of at least three. 
A shapefile has a shp part (this stores the geometry), a dbf part (this is the 
attribute table) and a shx part (an index file). Without all three of these 
parts it won’t work.  
 
The prj part isn’t essential but it’s often part of the file package and 
contains the projection information. It’s a tried-and-tested file format in 
GIS and it works well for most people. A more modern equivalent is the 
GeoPackage – it looks and feels the same but there is just one file, and it’s 
a lot more versatile (e.g. column names can be longer than 10 characters). 
 
At present the GIS world is in a bit of a transition period between the 
shapefile and the GeoPackage but that doesn’t matter much to us today. I 
just want you to be aware of the different file types – and that for mapping 
the differences are often negligible. 
 
I prefer to use the GeoPackage because it is cleaner and more versatile. 
 

 Using the Zoom In  button, click and drag to zoom right 
in to New Zealand so you can see the country and cities. 
 

 Via Project > Properties.. > General change the Background 
color to a nice blue again to make it look more like ocean. 

 
Time to save your work 
Save your project – e.g. as qgis_intro_p11 and then head  
to the next page. Remember to save your work regularly as you go 
through the workbook, just in case disaster strikes. 
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3. Styling data – make it look nice 

Use the Zoom Full  button so that you’re looking at the full 
world, if you aren’t already. We’re going to make it look nicer, but 
first we need to do something about all those dots. So, let’s take 
a quick detour into filters. 
 

 Right-click the 3_world_cities layer and select Filter… and 
you’ll see the Query Builder. This allows us to filter our data 
using an expression, so we only see part of it.  
 

 We’ll do more of this later on but for now, in the Fields box, 
double-click capital and then the = button below 
Operators and then, with capital selected under Fields), 
click the All button to see the options. Double-click primary 
to add it to the expression. 

 
 Once you see "capital" = 'primary' in the expression box you 

can click Test to check it will work, OK to confirm the query 
and OK to apply it. See below for how the query should look. 
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You now have two map layers with countries, and one with 
cities. Now it’s time to make them look better. You can access 
the Symbology for a layer by double-clicking it but we’ll use the 
Layer Styling panel in QGIS instead because it’s really simple.  
 

 If you don’t already have the Layer Styling panel on, 
activate it via View > Panels > Layer Styling. Once you’re 
there, make sure the top countries layer you can see on the 
map is the one named at the top of the Layer Styling panel 
and change the colour of the layer to a nice green colour. 
We’ll style the other country layer later on. 

 
 Using the layer selector 

dropdown, change to the 
3_world_cities layer and 
change the dots to size 1.5 
with a white Color. 
 

 Using the EPSG button 
(bottom right of the QGIS 
window), set projection to 
World_Robinson. Click OK. 
 

Top tip 
To change the Stroke color (i.e. the outline) rather than the Fill color for  
a layer, click where it says Simple marker or Simple fill and you can change 
its properties. I usually change the Stroke width for polygons to 0.15, rather 
than the default 0.26 - I find 0.26 a bit thick. Note the Live update tick box 
and Apply button at the bottom of the Layer Styling panel. 



Making Meaningful Maps, with QGIS           automaticknowledge 

15 
 

Notes 

You’ll get better at using all the options in the Layer Styling panel 
with more practice, but we only have time to focus on the 
fundamentals today. So, with that in mind, let’s add some labels. 
 

 Click the Labels  icon in Layer Styling for the cities layer 
and you’ll see that it will say No labels. 

 
 I said before that I didn’t want to turn anyone into a 

robot, so have a go at labelling the cities yourself 
now. To get started, change No labels to Single labels 
(using city as the label Value) then explore the different 
label options via the tabs shown below. I’ve also provided a 
screenshot of my label setup. I’ll do a demo of this shortly. 
 

 
 

 

I’ll do a live demo 
of this so you 

can follow along 
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Follow along demo time  
I want to give you more of an extended insight into labelling in QGIS 
because it is so important and it can make or break  
a map. We’ll look at the following options, via Layer Properties: 
 
Text – using a nice font is super important. So is colour.  

Formatting – want to use all UPPER case, or all lower? We can do it all here. 

Buffer – this describes the ‘halo’ or ‘glow’ around the label lettering. 

Background – we can also use a background for our labels. 

Shadow – this can be a really nice effect, but you need to be careful. 

Callouts – not often needed, but can be really helpful. 

Placement – again, this can absolutely make or break a map. 

Rendering – this includes things like only seeing labels at some scales. 
 

Did you notice from the screenshot 
on the previous page that my 
coastline had a nice soft glow 
around it, to kind of ease the 
contrast between land and sea? 
Well, that’s another useful trick in 
QGIS – achieved using Draw effects 
and accessed via Layer Rendering.  
 
You’ll find Layer Rendering at the 
bottom of the Layer Styling panel, 
on the Symbology section. Tick the Draw effects box, and then 

the little star  for the settings. You can see the settings I’ve 
used in the screenshot above – try and do something similar.  
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Top tip – how to export to a new layer (e.g. shapefile) 
The cities layer you’re working with is a text layer that QGIS can map. 
If you want to save the cities layer as a GeoPackage or shapefile, so that 
you have a permanent, mappable cities layer, then you can do this by 
right-clicking the layer and then Export > Save Features As… and then 

choosing the Format, then where to save it via the Browse  button, 
giving it a File name and then hitting Save and then OK to finish. 
 
N.B. If you save to a new layer when you have it filtered, only the filtered 
features will be in the new layer. You can do this with any kind of layer and 
it’s useful if (e.g.) you want to save a copy of a layer, or save it in a different 
file format – like if you want to save a shapefile as a GeoPackage. 

 
Here’s my screen at this point. Let me know if you need help. 
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We’ve just symbolised the countries using a simple colour. Now 
let’s symbolise the countries layer in different ways. There are a 
couple of ways we can do it, but the main ways we’d do it are as 
follows. Read the two bullet points first and then try it yourself. 
 

 Categorized – this is where you style a layer using some 
kind of category data in the Attribute Table. We have quite 
a few category fields in our countries layer – have a look at 
the Attribute Table and you’ll see them (e.g. REGION_WB is 
the World Bank region for each country). Categories are 
usually words, but of course they could also be numbers 
(e.g. to represent land use classes). 
 

 Graduated – this is where you style a layer using some kind 
of numerical value – e.g. like GDP per capita or population 
density, and then use a colour scale to show the 
graduation between high and low values. This is known as 
a choropleth map. The ‘choro’ bit relates to area or region 
– from the Greek χῶρος – and the ‘pleth’ bit relates to 
quantity, as in ‘plethora’. 

 
These styling options can be accessed via the Layer Styling 
panel in QGIS (also via Layer > Layer Properties… > Symbology). 
 

 Using your spare world_countries layer have a go at styling 
the layer using Categorized and then Graduated methods. 
Make sure the layer is visible in the map view – i.e. untick 
the other one if it’s on top. I’ll do a live styling demo soon. 
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You can see in my 
example to the right how 
I’ve chosen to symbolise 
my 1_world_countries 
layer using a 
Categorized method 
and using the 
REGION_WB Value from 
the Attribute Table. 
 
This colours all world 
countries by their World 
Bank Region. 
 
The only thing you 
REALLY need to do here is 
remember to hit Classify 
once you’ve chosen your 
symbology scheme. 
Otherwise nothing will 
happen! 
 
When you change to a 
new classification, QGIS 
will ask if you want to 
delete the previous one 
– you can click Yes if this 
happens.  

How I feel 
when I 

forget to 
click 

Classify 

Where did it 
all go wrong? 
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Top tip – show how many features are in each category/class 
When you’ve symbolised data into different categories, it’s often  
important to be able to tell how many features are in each category or 
numerical class. Right-click a layer name in the Layers panel on the left, 
and then tick the Show Feature Count box to see how this works. 
 

Now it’s time to take a bit more of an in-depth look at 
Symbology, using the layers we have on the map. You can 
follow along as I go and ask any questions as they arise. 
 

Follow along demo time  
I’ll do a follow along live demo of Symbology now. 
 
Whether I do it via the Layer Styling panel, Layer > Layer Properties… or just 
access the Layer Properties by double-clicking on the layer name (I find 
this way quickest and easiest), it always takes me to the same place. Or 
click this icon!  Let’s look at the following ways of symbolising a layer.  
 
Categorized 
Let’s try to categorise using some of the different fields in our countries 
dataset, including CONTINENT, MAPCOLOR13, SUBREGION, and so on. So long 
as we keep hitting Classify, we’re going to be successful.  
 
Classified 
We can also create different kinds of choropleth map using the data in the 
Attribute Table. We can map totals here, but normally we shouldn’t so we’ll 
look at how to standardise by population. Classification Mode? That’s 
things like Equal Count (Quantile), Natural Breaks, etc. We’ll look at this. 
 
Using expressions  
We can do this using the Categorized or Classified methods – using 
calculations or by extracting values from strings. Be amazed! 
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Time to save your work again 
Save your project now – e.g. as qgis_intro_p20. 
 
I won’t add in this save box again because I’m sure you can remember 
yourself but I will add in the save icon occasionally as a little reminder. 

 
Here’s a screenshot of what I have at this point – for reference. 
 

 
 

Okay, so we’re making maps now. That’s great. Want to know 
how to save a style within a layer, or as default? Just ask me. 
 
But of course any GIS work is about much more than maps – or 
at least it should be. It’s also about querying data, doing spatial 
analysis, and mapping new things. We’ll look at these next, 
beginning with how to join data from a spreadsheet to an 
existing map layer. 
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4. Joining data – map anything! 
So far we’ve done some basic things, including: 
 

 Exploring the QGIS interface; 
 Adding different kinds of data to QGIS; 
 Styling layers in different ways. 

 
Now we’ll look at how to join data in QGIS. Here’s an example of 
how this typically works (after this, you’ll have a go yourself). 
 

1. You have some map data in QGIS (e.g. a shapefile) of all 
the countries in the world – like we do right now. In the 
Attribute Table of this layer you have a column with a three 
letter code for each country (e.g. the ADM0_A3 column). 
 

2. You decide you want to explore, compare and map 
country populations, so you find a spreadsheet online with 
the data (i.e. like our dataset 4 xlsx file). The spreadsheet 
also has a three letter code for each country and these 
codes appear to match the country codes you have in 
your shapefile, so you’re all set. 

 
3. You then join the spreadsheet data to your map layer (it 

could be a shapefile. GeoPackage or any other geospatial 
file format) and then once the join is done you can then 
map the previously unmappable spreadsheet data. 
 

Let’s have a go at this now. 
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 You should already have the 
4_world_bank_population_data_1960-2019 file in your 
QGIS Layers panel, but if not, add it now. Open the Attribute 

Table  and then you’ll see that the file has a Country 
Name column, a Country Code column, and then 
population data for each year from 1960 to 2019. 

 
 If you sort the columns by clicking on (e.g.) Y1960 you’ll see 

that the file contains data for the world, and different world 
regions – this isn’t a problem though, because QGIS will 
only join the data where there is a matching country code 
in both datasets. You can close the Attribute Table now. 
 

 Double-click the 2_world_countries layer and then go to 
the  Joins area to the left of the Layer Properties window.  
 

 Start the join by clicking the little green plus  to the 
bottom left of the Layer Properties window. 
 

 You will then see the Add Vector Join options. This can be 
confusing at first but all you are doing is telling QGIS which 
data you want to join to the existing map layer, which 
columns (aka ‘fields’) your matching country codes are in 
– plus some other options. 
 

 Take a look at the next page and make your Add Vector 
Join settings look like mine. When they do, click OK, then OK. 
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 Once you’ve clicked OK to create the join and then OK to 
exit Layer Properties the join will be complete – but how do 
you know?  

 
 You can see the join has been successful by opening the 

Attribute Table of the layer you just joined the spreadsheet 
data to (in my case it was 2_world_countries) and then 
scrolling right to see the newly appended data. 
 

 This is what I always do once I’ve performed a join – just to 
check it. Have a look yourself now and you should see all 
the country population data. Follow the instructions in the 
box on the next page to export the joined layer. 

MAKE SURE THE BOX IS TICKED 
AND THIS FIELD IS EMPTY 

THIS IS WHAT IT 
SHOULD LOOK LIKE 
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Remember this 
When you perform a join like this, it’s not a permanent thing. 
 
Think of it more like a temporary connection between files. If we want to 
permanently save the joined data, we can export it as a new layer in QGIS. 
This is done via a right-click from the layer we joined the data to (i.e. right-
click the geographic layer you joined the data to, not the one it came from. 
 
Then it’s a case of Export > Save Features As… and save the new layer in 
your preferred format, with a meaningful name. Note that when you are 
exporting to a new layer, the Save Vector Layer as… options in QGIS allow 
you to select which fields to include in the export – that is, you get the 
choice of which Attribute Table columns to include in the new layer – very 
useful if you only want a few of them. 
 

 I saved my new joined layer as 
2_world_countries_with_pop_data.shp and it then added 
to the map as a new layer. Make sure you’ve done this too, 
though don’t worry if your file name or format is different. 
 

If you ever need to edit a Join, you can do this by going back to 

Layer Properties > Joins and clicking the little pencil  icon. 
 

 Sort the Y2019 column of your newly joined layer by clicking 
on the column header. Lots of NULL values? Have a look at 
which countries or areas these are. Ask me about it if you 
have any questions. 

 
 Let’s remove Antarctica. Right-click the new layer, then 

Filter… then use this query: NOT "SOVEREIGNT" = 'Antarctica' 
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5. Exploring data (including base maps)  
The idea in the early part of this workbook is to get you up to 
speed with QGIS, as well as just becoming familiar with the 
interface – how it looks, where to find stuff. That’s why it was 
more step-by-step. As we go on, we’ll do less of that, starting 
from now, but if you need me to demo something, let me know.  
 
It’s often very useful when doing any mapping to be able to add 
a high resolution base map (e.g. Google Maps, Bing Maps, or 
OpenStreetMap). Let’s add one of these in right now. 
 

 Turn off (untick ) all your map layers apart from the 
3_world_cities layer . In the Browser, expand (via little 
black triangle ) XYZ Tiles, then double-click 
OpenStreetMap to add it to the map. 

 
 Change the projection to WGS 84 / Pseudo-Mercator 

(remember, via the little EPSG button in the bottom right). 
This is the projection you’ll need to use to ensure any XYZ 
Tiles maps are 100% crisp and not slightly fuzzy-looking. 
 

 Zoom  and Pan  and explore the map a little – for 
example, check if the city points you imported earlier via 
the csv file are in the right place on the map. 
 

 Change the Query on the world cities layer (via ) to 
"country" = 'Belgium' AND "population" > 100000 and have a 
closer look. You can use  to quickly zoom in to layers. 
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 Change your OpenStreetMap base layer to 50% 
Transparency and in Symbology to Grayscale > By 
lightness. 

 
Here’s what my map currently looks like – below – based on the 
following query: "country" = 'Australia' AND "population" > 150000 
 

 
 
The base map here provides some additional context, though 
isn’t strictly necessary – but it can often be really useful. 

YOU CAN UNTICK THE OSM BASE MAP 
LAYER NOW, PUT THE PROJECTION 
BACK TO WORLD_ROBINSON AND 

TURN THE COUNTRIES LAYER BACK ON 
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6. Querying data – start asking questions 
The idea behind this part of the workbook is that we start asking 
questions of our data and using queries to find the answers. 
 

Here’s an example: The World’s Cities in 2018 report from the 
United Nations identified Tokyo as the world’s largest urban 
agglomeration (they call it ‘city’ but really it’s the wider urban 
area), with a population of 37,468,000. We want to see how 
many countries in the world have a lower population than this, 
and then map it. 
 

 Run this Filter… on your new country + population layer: 
"Y2018" < 37468000 AND NOT "SOVEREIGNT" = 'Antarctica' 
(note that the ‘AND NOT…’ bit just keeps Antarctica turned 
off). See below for my results (I’ve turned the projection 
back to World_Robinson here – you can do this too). 

 

 

Tokyo metro area has a 
lot of people in it! 
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Note that in QGIS you can use this same query syntax to select 
features as well. For example, if you wanted to select all 
countries with a lower population than ‘Tokyo’ and then Export 
the selected countries to a new layer. The query is the same, but 
you’d do it via the Select Features by Expression… button (as 
shown below).  
 

 
 
How do you know how many countries are included in a Filter or 
Select operation? You’ll always see this information at the top of 
an Attribute Table’s window, and for a Filter you can see the 
number of features via a right-click and Show Feature Count. 
 
On the next page I’ve set you a series of questions that can be 
answered using the map layers we have. Can answer them all? 
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Q: In the 3_world_cities layer, how many cities have a 
population of more than 20 million?  
 
A:  
 
Q: Of the above cities, how many are capitals? (hint: 
"population" > 20000000 AND "capital" = 'primary') 
 
A:  
 
Q: How many countries have a population of more than 100 
million? 
 
A:  
 
Q: How many 1. High income: OECD countries have a population 
of more than 100 million? (hint: you might use AND twice here) 

 
A:  
 
Q: How many countries start with A, B or C? (hint: undo previous 
Filters, then do this one via Select Features by Expression…  
and then with this text left("GEOUNIT",1) IN ('A','B','C')).  

 
A:  
 
We know how to do queries - let’s look at spatial analysis next.  



Making Meaningful Maps, with QGIS           automaticknowledge 

31 
 

Notes 

7. Spatial analysis: beyond maps 
QGIS can display maps, as you’ve seen. You have also seen how 
you can query the data behind those maps. 
 
Let’s take a look at how to do some simple spatial analysis tasks.  
 

 First make sure nothing is selected on your map (Deselect 
Features from All Layers ) – it’s also a good idea to save 
your project now, adding the page number to the project 
file name like before. 

 
 Now make sure a countries layer is visible, and unfiltered 

(it’s fine if Antarctica is still turned off with a filter though). 
 

 Now, with your countries layer selected in the Layers panel 
on the left, use the Select Feature(s)  tool to select the 
Democratic Republic of the Congo – just click on it. 
 

 Now go to Vector > Research Tools > Select by Location… 
and, using  Selected features only,  Run the query, just 
like in the screenshot below (you may be using a different 
countries layer, in which case that’s fine). 
 

 Keep the Select by Location window open, and keep 
reading on the next page. 
 

 
 



Making Meaningful Maps, with QGIS           automaticknowledge 

32 
 

Notes 

 
 

 You should now see that all countries that border the 
Democratic Republic of the Congo are selected. Now keep 
pressing Run and QGIS will select the countries that border 
those, and so on and so on. Then Close the Select by 
Location window and unselect  all features. 

 
 Now I want you to select Bolivia  from your countries 

layer, turn on your 3_world_cities layer, plus a countries 
layer, and go back into Vector > Research Tools > Select by 
Location… and then select all cities that are within the 
selected features of the countries layer. This is a simple 
point-in-polygon GIS operation where QGIS is able to 
select features from one layer, based on another. 

MAKE SURE THE BOX IS 
TICKED – IF NOT, THE 

WHOLE WORLD IS 
SELECTED! 

YOU MAY HAVE USED A 
DIFFERENT COUNTRIES 

LAYER HERE, THAT’S FINE 
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Here’s what the Bolivia query above looks like on my machine. 
 

 
 

 If your Select by Location query didn’t work first time, try it 
again using the options above. It should select 78 places. 

 
 I also want you to click on the Help button to see what 

happens – this is so useful because it takes you directly to 
the QGIS help pages. You can close Select by Location now. 
 

That’s the end of our little spatial analysis mini adventure for 
now – now it’s time to make some pretty maps!  

We used are within 
here, but as you can 
see there are many 

different options you 
could use. 
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8. Using the Print Layout to make a map 
We’re going to spend some time now looking at how to create a 
nice map in the Print Layout. This is the area of QGIS where you 
design, edit and export high quality maps. The main map 
viewing window is generally where you explore, analyse and 
investigate data – although it is also possible to export high 
quality, production-ready maps directly from the main map 
view as well (though with fewer features). 
 
Here’s what we’re going to create (below) – if you want to do 
some variation of this, that’s fine with me.  
 

 
 
https://automaticknowledge.org/training/data/styles - this is 
where you will find the layer style files (qml) and this image. You 
can load styles via Layer Properties then Style > Load Style.  

https://automaticknowledge.org/training/data/styles
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I’ll get you started with the Print Layout tools, do a bit of a follow 
along, and then you can take it from there. But first, do this: 
 

 Open a new Print Layout in QGIS– you can do this via the 
New Print Layout button , via Project > New Print Layout… 
or via CTRL+P (on Windows) and ⌘+P (Mac). 

 
 Give the new Print Layout a name, when prompted – I 

called mine Megacities. 
 

You’ll then see something that looks like a blank piece of 
white paper on a grey background – as below. Have a close 
look at it, then go to the next page where we’ll work through it. 

 

 

This is the Item 
Properties tab – 
everything you 

add to the page is 
an Item and can 
be edited here. 
You’ll use this a 

lot. 

To set the Page Properties, including size and 
background colour, right-click and select Page 

Properties… and then edit them in Item Properties. 

The single most important button – this adds 
your map to the page. 

All Items will appear 
here – use the tick box 

to show/hide. 

Tools to position 
and align Items. 

Zoom to full page 

Refresh page 

Move map within frame 

Select and move an item 

Use these tools to add a legend, text, image, shapes, 
scale bar and north arrow. 
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Follow along demo time 
Okay, time to get the layout as we want it, so try to copy me. 
 
Here are the steps I’ll go through so you can follow. 
 

 I normally set the page size to 320.00mm x 180.00mm because this is 
the correct aspect ratio for full screen viewing (i.e. 16:9). But you can 
choose pre-set page sizes, including A4 and US Letter sizes. 

 Next, I usually add a map – with a simple click and drag. I will often re-
size this to match the page size, but sometimes I leave a white border. 

 Note that when you move Items around a Print Layout they ‘snap’ to 
centre, middle and edges, as well as each other. This is very helpful. 

 Then I’ll edit the map scale via Item Properties on the right.  
 Then I’ll position the map inside the frame using Move item content. 
 Then I’ll add text (title, source, annotations), and re-position/re-size. 
 I often go back to the map data to tweak the symbology as I’m doing 

this, if I’m not happy with anything. 
 Sometimes I use the built-in Legend tool, sometimes I add shapes 

manually, then copy them to create my own legend. 
 I usually only add a north arrow and scale bar if it’s essential. 
 I tend to prefer a subtle off-white colour for the background, with a 

white border to help focus the eye on the main map frame. 
 I use #222222 for dark text rather than #000000 (100% black). 
 If I add an image, I always try to use a svg, they tend to look crisper. 
 A subtle title guide line (as in the example above) is a nice touch. 
 I try to achieve visual balance, and object alignment. 
 When I’m happy with it, I go to Layout > Export as image… and then save 

a 300dpi png. Then I inspect the exported map closely and go back and 
fix things I don’t like – often many times. 

 I make sure I save my project here as I go, just in case disaster strikes. 
 I often add some kind of explanatory text and/or annotation to the map, 

and make the title as clear as possible. 
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Here’s a screenshot from my Print Layout, the same one that 
generated the image I showed you previously. 
 

 
 

If you’re used to other GIS software, or none, then the QGIS Print 
Layout can be baffling, frustrating or both. I felt the same way 
when I first started using it, but once you get over the initial 
‘what the #!@*&%!?’ feeling, you have so much flexibility and 
freedom to create great maps and graphical layouts. 
 
If you remember this basic approach, though, you should be ok: 
 
Add an item (map, shape, text box, etc.) to the Print Layout. 
Edit its properties in the Item Properties tab. Refresh Print 
Layout if you change any of the map content. Navigate map 
within layout using this button . Save project. Save map via 
Layout > Export as image… 

Notice how my map frame is 
slightly smaller than the 

320x180mm page – leaving a 
white border round the page. 

Tick/untick to 
show or hide. 
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The best way to become proficient with the Print Layout is to 
spend time experimenting with it, and using it for real. 
 
The only other thing to add here is that when you add a Legend, 
by default all the layers you have in your map will be in it. See 
the little ‘BEFORE’ and ‘AFTER’ comparison below where I have 
shown the default on the left, and the edited Legend on the right. 
 

 
 
Top tip 
This  button is how you select/move individual Print Layout items. 
 
Use the little zoom tool in the bottom right of the Print Layout window to 

inspect in detail how your final export will look.   

Yeah, we don’t 
need all these! 

I unticked ‘Auto 
update’ and used 
these buttons to 
remove things I 

didn’t want. 
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9. Exporting maps (two ways) 
You can export maps from QGIS in two main ways.  
 

1. Export a map from a Print Layout, as we have seen above. 
You can export in lots of different formats, via Layout > 
Export as Image… or by clicking one of these three buttons 

 (the first is for image formats like png, the next 
is for svg and the final one is for pdf exports).  
 

2. You can also export maps directly from the main map view 
in QGIS, using Project > Import/Export > Export map to 
Image… - this is less flexible but it can also be really useful. 
Also, once you’re in the Export map to Image… options, you 
can choose to Copy to Clipboard and then paste your map 
into another application (e.g. into a slide show, or email). 
 

In general, I’d say always use the first option above if you want 
to create the highest quality maps, but if you’re just looking to 
export a map view to provide a general overview, or to show 
someone what you’re working on, the second option is very 
useful. You should be able to open the svg in a web browser. 
 

 From the Print Layout you currently have open, try to export 
your map once each as a png (300dpi), jpg (300dpi), pdf 
and svg – if there’s time for this. Once you’ve done it, 
compare them – e.g. image quality, details and so on. I 
always recommend a 300dpi png when exporting maps.  
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This kind of experimental exporting and comparing of formats is 
not something most people think about doing, but it can be very 
helpful. In general a 300dpi png is preferable over a 300dpi jpg 
because the png is a ‘lossless’ file format and what you see in 
your Print Layout is what you’ll get in the final file, quality-wise.  
 
With jpg, you will often notice a fuzziness, particularly with red 
shades, because it is a ‘lossy’ file format. 
 

 Now go back to your main QGIS map view, and at this point 
I’d recommend saving your project again – as before, with 
the current page number added to the project file name. 

 
 Before we go to Project > Import/Export > Export map to 

Image… I want you instead to do the following: go to View > 
Decorations and then you’ll see the following options, 
below. 
 

 You can add a variety of different 
Decorations, as QGIS calls them. When you 
go to export images in this way, these 
Decorations will be included in your image 
file, unless you untick the Draw Annotations 
box in the Save Map as Image window. 
 

You’ll find these options simple enough to use, so see if you 
can replicate my screenshot below, with Title Label… 
Copyright Label… (used for the ‘Source’ text) and Image… 
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 Once you’re happy with the way your map looks, go ahead 
and export it as a 300dpi png or as a pdf. 

 
 If you’ve come this far you’ve done well! Save your project 

once again, take a deep breath, and then go to the next 
page.  
 
 

Baffled? 
Are you baffled, mildly confused, just wondering about something? 
If so, that’s 100% to be expected because there is a lot of material in here – 
so long as you have mastered the fundamentals and know your way round 
QGIS that is great. But feel free to ask me anything now, or later. 

Click to change Font 
size/colour etc. 

This is the 
Copyright Label 

text. 
This is using the Image option. 
You may find the QGIS svg is in 

there by default, like mine. 
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10. Putting it into practice 
If you’ve reached this point before the scheduled end of the 
training session, that’s great – you can now continue and 
perhaps take things a step further (but feel free to chill, go off in 
your own direction, or just ask me anything). With this in mind, 
here are some suggestions for ways you can put all your QGIS 
skills into practice, now or in the future. 
 
 You could do some more filtering and/or labelling on different 

layers – e.g. using the explanatory text in the 
3_world_cities_megacity_2030.qml layer I provided in the 
data/styles folder you could try and experiment further.  

 
 You could do a map of all world countries with a lower 

population than Tokyo’s metropolitan area – you may 
remember I shared an example of this earlier on. 

 
 You could do a map showing countries with the highest 

population growth over a certain time period – this could be 
done by as a Graduated symbol with ("Y2019" - "Y1960" ) /  
"Y1960"  * 100 used in the Value field. 

 
 I mean, you could do just about anything, including a 

Categorized style, mapping all countries that start with an I – 
using this in the Value field: left( "GEOUNIT" ,1) = 'I'. 

 
If you have any questions after this session, or you just can’t 
figure something out, feel free to get in touch. 
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11. Credits 
 
QGIS - QGIS is a user friendly Open Source Geographic Information System 
(GIS) licensed under the GNU General Public License. QGIS is an official 
project of the Open Source Geospatial Foundation (OSGeo). 
https://www.qgis.org/en/site/about/index.html  
 
Natural Earth – ‘no permission is needed to use Natural Earth data’. All 
versions of Natural Earth raster + vector map data found on this website 
are in the public domain. 
https://www.naturalearthdata.com/about/terms-of-use/ 
 
SimpleMaps – World Cities Database (Basic), used under the Creative 
Commons Attribution 4.0 licence. 
https://simplemaps.com/data/world-cities 
 
World Bank – Population data, used under the Creative Commons 
Attribution 4.0 licence. 
 
https://data.worldbank.org/indicator/SP.POP.TOTL 
 
Emojis are from Twemoji, at twemoji.twitter.com, licenced under the CC-BY 
4.0 licence. 
https://twemoji.twitter.com/ 
 
Poppins Font - Designed by Indian Type Foundry, Jonny Pinhorn, licenced 
under the Open Font Licence. 
https://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&id=OFL 
 
 
 

https://www.qgis.org/en/site/about/index.html
https://creativecommons.org/licenses/by/4.0/
https://creativecommons.org/licenses/by/4.0/
https://creativecommons.org/licenses/by/4.0/
https://creativecommons.org/licenses/by/4.0/
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12. Useful links 
Natural Earth – the best source for easy-to-use global map data, e.g. 
countries, places, states, roads, coastlines and much more. 
https://www.naturalearthdata.com 
 
simplemaps – world cities csv files, with lat/long coordinates. This is a 
great source for place name data. 
https://simplemaps.com/data/world-cities 
 
Sentinel-2 cloudless – for adding satellite imagery to QGIS. Right-click 
WMS/WMTS in the QGIS browser panel, then click New Connection… add 
Sentinel-2 cloudless to the Name and the second url below to the URL field. 
https://s2maps.eu/ 
https://tiles.maps.eox.at/wms?service=wms&request=getcapabilities 
 
OS OpenData Downloads (Ordnance Survey) – a huge amount of free, 
open geospatial data are now available from Ordnance Survey via their 
Open Data Hub. The data covers Great Britain and no registration is 
required. 
https://osdatahub.os.uk/downloads/open 
 
ONS Geography Portal (UK) – see the Boundaries section of this website 
for a wide range of UK boundary data. This site includes data for the whole 
of the UK, whereas Ordnance Survey data only covers Great Britain. A great 
resource. 
https://geoportal.statistics.gov.uk/ 
 
QGIS Documentation – the official help docs from the people who make 
QGIS. 
https://www.qgis.org/en/docs/index.html 
  

https://www.naturalearthdata.com/
https://s2maps.eu/
https://tiles.maps.eox.at/wms?service=wms&request=getcapabilities
https://osdatahub.os.uk/downloads/open
https://www.qgis.org/en/docs/index.html
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Back page cheat sheet 
These are things I use myself – to make things work faster, better, smoother.  
 CTRL+Tab turns panels on/off so the map area is full screen width. 
 Select some features, Edit > Copy Features then Edit > Paste Features As a new 

temporary layer (called a ‘scratch’ layer) or a new vector layer. 
 F11 for full screen mode, F1 for QGIS User Guide, F6 to open Attribute table (on Windows). 
 CTRL+Shift+Tab for full screen map mode (on Windows). Same again to undo. 
 Change projection for project (it doesn’t alter any data) via EPSG button, bottom right. 
 Black is too harsh, try #222222 / RGB 34, 34, 34 instead. Go beyond default colours! 
 Where is your layer stored? Double-click a layer, go to Information and see Path. 
 Turn on the thousand separator (1,000 vs 1000) – Settings > Options > General, tick box. 
 Want to save the position of your map? Use View > New Spatial Bookmark. 
 Print Layout looking fuzzy? Just hit refresh and that will fix it. 
 Print Layout page not zooming to full extent? Re-size your page, then reset to original. 
 Save your most commonly used data source paths as Favorites in the Browser. 
 When styling layers, you don’t have to use only the columns you already have – e.g. 

you can style based on calculations or even by extracting portions of text. 
 Hey, my lovely XYZ base map looks a bit fuzzy! Set projection to EPSG:3857. 
 Hey, my joined layer has weird column header names! Go back into Joins, and edit the 

join so that the Custom Field Name Prefix is ticked and the box is blank. 
 How do you do those glowing lines/polygons? That’s via Blending mode in Symbology. 
 Help! My side panel things have disappeared. Go to View > Panels. 
 Use Inverted polygons with a filter and a satellite base layer to create nice area maps 

– make layer white/black and use about 75% Opacity. 
 Go to Processing > History to view or re-run your recent geoprocessing tasks. 
 A general carto tip: try to make your map as simple as possible, remove any junk. 
 Type world into the Coordinate box if you want a world countries layer to use. 
 Use a 16:9 aspect ratio if your maps are mainly for screens (e.g. 320mm x 180mm). 
 Map a list of x and y coordinates quickly via Delimited Text in Data Source Manager. 
 Drag and drop files from your file browser directly into QGIS (e.g. shp, gpkg etc). 
 You can add layers via the WMS/WMTS option in Browser. Just Google it. 
 Want to save/re-use a map style for a layer? Layer Properties > Style > Save Style…  
 If you give the qml file the same name as a layer file and put it in the same folder as 

the file then when you add it to QGIS that style will be applied by default. 
 Learn about Draw effects! Use them to add a glow or a shadow to features. 
 View > Preview Mode to see your map in colour-blind safe modes or greyscale. 
 Best Plugins? MMQGIS, SRTM Downloader, Build Globe View, Qgis2threejs, qgis2web. 
 Add base maps via XYZ Tiles in Browser panel. OpenStreetMap is there by default. 


